Jump to content

Bridge Pickup Doesn't Work.


eXCeSS

Recommended Posts

so i get my new explorer with duncans annnnd the pickup is REALLY quiet

about 5% of the neck one.

heres the pictures of the inside of the little compartment

http://www.mcccxxxvii.com/up/explorer/

if any of you could tell me what the deal is and if i can fix anything on my own with out shelling out the money for it to get professionally done id appreciate it greatly

i think theres 2 volume and one tone becuase 2 have the same ingravings on the back and one is different

help

Link to comment
Share on other sites

Did you buy it from a store? If ya just got it and you bought it from a store, just go back to the store and ask them if they will fix it. If not, do you know how to solder? Do you know how to check the pickups to see if they are shorted or open? If not, you should probably see a pro. Not trying to discourage you from fixing your own guitar, but based on how you asked your question, and your post number, it seems your a bit inexperienced. I would hate to see you damage your electronics or your finish to save 20 bucks.

Link to comment
Share on other sites

Did you buy it from a store? If ya just got it and you bought it from a store, just go back to the store and ask them if they will fix it. If not, do you know how to solder? Do you know how to check the pickups to see if they are shorted or open? If not, you should probably see a pro. Not trying to discourage you from fixing your own guitar, but based on how you asked your question, and your post number, it seems your a bit inexperienced. I would hate to see you damage your electronics or your finish to save 20 bucks.

i can solder pretty well and i have a multimeter around here somewhere

is there a few things i can check to help fix this as i want to play my guitar!

and i got it off ebay (it was listed as perfect so something might have happended in transit)

so yeah is tehre like things i should check with the multimeter to see if there s anosrt or now

please help thank you

Link to comment
Share on other sites

sounds like one of the possibilities is that it's wired out of phase. if you're good at soldering trace the two wires comimg from the problem pickup to where they're soldered..reverse their positions and see if that fixes it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...